You can add Vimeo videos to your slides and signs with the Vimeo app in the MangoSigns Editor. Simply click on the Videos icon in app bar, then click on Vimeo Videos. 

From here you will see a popup that asks for the Video url as well as a number of options described below for the Vimeo video playback.

Video/Playlist Url: Paste the url of the Vimeo video, or video playlist you would like to show on your slides.

Auto Play: If enabled, the video will start playing when the slide loads. (Please note that if you are using google chrome, or the chrome app, you will need to enable autoplay - No User Gestures Requred. See the troubleshooting section below for how to enable).

Loop: If enabled, the video will automatically loop once it is finished. 

Show Title: Will show the title for the Vimeo video the entire time the video plays.

Show Captions: If enabled, captions will show for a video if they are available. Please note that captions have to be available and enabled for the video for captions to show.

Pause Video: If enabled, the video will pause at the end of the slide, then resume where it left off when the slide is shown again.

Advance on End: If enabled, the slide will advance to the next slide when the video ends. Please note that the timing on the slide will need to be longer than the video for this to work.

Troubleshooting

If you are having an issue with videos playing in the Chrome browser or on your Chrome device, you will need to enable the autoplay setting.

** Update Chrome Versions 76 and Greater **

For chrome versions 76 and greater, allowing sound to autoplay will enable autoplay to work within your chrome browser. To allow autoplay, follow the steps below.

In your Chrome browser, navigate to chrome://settings/content/sound?search=sound

From there, you should be able to Click on the Add button next to allow and enter https://app.mangosigns.com

For Chrome versions prior to 76, see the instructions below.

Here is how you configure the setting:

  1. Load the following url into the chrome browser - chrome://flags/#autoplay-policy  . 
  2. Click on the menu next to it, and select the option -  No user gesture is required
  3. Now refresh the page and the video should now autoplay on preview.
Did this answer your question?